Author Topic: Choke Heating Element Configuration  (Read 126 times)

0 Members and 1 Guest are viewing this topic.

Offline Achilles

  • Full Member
  • ***
  • Posts: 105
    • Ghia Blog
Choke Heating Element Configuration
« on: 07 November 2019, 16:30 »
Shot in the dark here.
Is there any difference in config of the choke heating element on Auto vs. Manual cars?
My rig is 1970 bone stock single port autostick Ghia with the original Solex 30 PICT 3. I overhauled that carb, and think I got it right but mmm y'know first time and all.

When rebuilding got a good quality replacement choke heating element from aircooled.net they have been good to us. Reason for replacement....later.
There is no option for an 'auto stick' version of element, as far as I can tell. So mushed on.

On this new element, the location of the coil hook relative to (+)ve terminal on the housing is a bit different than on the original. The alignment mark on the element housing is therefore in a different location. When installing the element, though, all is well. Aligned the mark on the element with the middle mark on the carb, or as per Rob & Dave's. This gets the choke butterfly to just closed position. So, the hook on the coil element is engaging the arm on the choke butterfly / cam shaft just fine.

The real reason for asking is that I seem to have done something quite wrong, that's why I got a replacement choke element. When the car warms up (which it does smoothly) the choke butterfly never seems to open of its' own accord, thereby dropping engine RPMs as it should. I have to kick down on the accelerator to get the cam to 'release' and drop the RPMs. From there it's smooth sailing, all things considered. This is the case regardless of whether the original or the new choke element is installed.

Any help is appreciated.
Larry

1970 AS Karmann Ghia Cabriolet

Offline volkenstein

  • Moderator
  • Hero Member
  • *****
  • Posts: 1388
Re: Choke Heating Element Configuration
« Reply #1 on: 14 November 2019, 02:43 »
Achilles,
           Pretty much working as designed. You will notice (*should* :) ) that when cold, if you cycle the throttle, the throttle positioner is actually riding on one of the cam steps. As the car warm's up - you can blip the throttle and  the TP will move according to the cars heat/throttle element etc. What you are experiencing would be considered "normal"....ie - the car will run faster as you HAVE NOT blipped the throttle to reposition the cam. When you DO this..it may/may not hit another step on that cam....what I recommend you have a look at it is when the beast is fully warmed...you are OFF the cam steps, and the choke is FULLY open - ditto  your flaps - fully OPEN (assumng you have a working standard thermostat). I'll have a hunt round the interweb to see what a 30 Pict 3 has fitted as most of my experience is 34 Pict 3 based..

HTH
Volkenstein
'71 RHD A-S Super - "Klaus"